首页 > 文章 > 杂文

composer 指定执行的php版本
时间:2022-05-13 11:22:07  点击: 来源:  作者:

系统中如果安装多个php版本的,在执行composer的时候有时候会报php版本过低的错误: composer require workerman/workerman #这里以安装workerman为例 发上命令为直接执行,php版本为系统默认的版本,下面我们来看下 ...

系统中如果安装多个php版本的,在执行composer的时候有时候会报php版本过低的错误:

 

composer require workerman/workerman #这里以安装workerman为例

 

发上命令为直接执行,php版本为系统默认的版本,下面我们来看下如何具体指定php版本:

 

/www/server/php/73/bin/php /usr/bin/composer require workerman/workerman

 

只需要在composer前面加上要使用php的版本路径和composer完整的安装路径即可,如下图:

 

 

支持
发表评论 共有条评论
用户名: 密码:
验证码: 匿名发表
推荐资讯
python安装扩展
python安装扩展
2022年 电脑显卡天梯图
2022年 电脑显卡天梯
centos7各代号与小版本号对应关系
centos7各代号与小版
vncserver启动报错 Failed to start Remote desktop service (VNC)
vncserver启动报错 Fa
相关文章
栏目更新
栏目热门

关于我们 | 广告服务 | 联系我们 | 网站地图 | 免责声明 | WAP | RSS


Copyright © 运维之家 2013-2022