composer 指定执行的php版本
2022-05-13 11:22:07   来源:   评论:0 点击: 收藏

系统中如果安装多个php版本的,在执行composer的时候有时候会报php版本过低的错误:composer require workerman workerman 这里以安装w

系统中如果安装多个php版本的,在执行composer的时候有时候会报php版本过低的错误:

 

composer require workerman/workerman #这里以安装workerman为例

 

发上命令为直接执行,php版本为系统默认的版本,下面我们来看下如何具体指定php版本:

 

/www/server/php/73/bin/php /usr/bin/composer require workerman/workerman

 

只需要在composer前面加上要使用php的版本路径和composer完整的安装路径即可,如下图:

 

 



相关热词搜索:composer

上一篇:gitlab设置只能维护者合并代码
下一篇:最后一页